My NET Rio 2 Cruising Premium pachislo keeps giving me error after error. These errors have been constant ever since I purchased the machine secondhand.

First off, the RAM gives me a Trouble error every time I start up the machine. So to fix this, I need to shut the machine Off, turn the Reset key to On, turn the machine back On, push the Bet lever once, turn the Reset key back to Off, then turn the machine back Off and On again just so it stops making the Trouble error noise. Every time.

I purchased the machine used, and the previous owner put a token into the slotís coin mechanism that was slightly too big. This caused a C5 error after inserting about 40 tokens into the slotÖevery time. It disrupted my gameplay on the machine frequently. I didnít know how to disassemble and reassemble the coin mechanism in the slot, so with a piece of paper, I jiggled the token up and down the coin mechís pathway (where it was stuck), until it somehow fell out of the bottom of the coin mech, down the ramp. I analyzed the token after it fell outÖsomehowÖand the token was rusted in some spots.

Iím not sure what this stuck token removal process did to the coin mech, because soon after some more gameplay that went normally, a CE error popped up. Apparently, this CE error has something to do with the coin mech. Perhaps it got damaged as I tried to get the big rusted token out? I didnít notice or hear much damage to the mech as I got the token dislodged. But then, why would it have worked normally (for like 5 minutes) after I got that big token out of there?

Iíve tried resetting the machine (as stated above) and it still reverts to the CE error. I am unable to play the game because of this CE error.

I inserted several coins through the coin slot as the CE error blared away, and while the error was not fixed, the coins did properly complete the circuit and were properly distributed into the coin hopper.

The included Youtube video that I made to show how the errors appear (which can be found here: ) shows what the coin mech looks like. I do not know how to disassemble it.

How do I permanently fix the annoying RAM error with my machine, and how do I permanently fix this CE error? Looking for help before I end up scrapping the machine.