Results 1 to 3 of 3

Thread: Pachislo Net machine power up issue blows 8 amp fuse

  1. #1
    Tokie Owens dynaglide36's Avatar
    Join Date
    Dec 2018
    Location
    Select...salmon arm
    Posts
    2
    Thanks
    0
    Thanks Received
    0

    Unhappy Pachislo Net machine power up issue blows 8 amp fuse

    Hi i have a pachislo Monkey magic Net machine that blows the 8amp fuse on power up. I have a transformer with 110 in and is putting out 30 volts to the 24 volt power supply. I have nothing else plugged into the power supply going out and it blows the 8 amp fuse. Just wondering if 30 volts is to high when its supposed to be 24v in ? when i do hook the plug in to the machine from the power supply everything comes on briefly before the 8amp fuse blows as with nothing hooked up. Any help would be much appreciated. cheers !!

  2. #2
    I was thrown out of Top Gear Drunkenclam's Avatar
    Join Date
    May 2010
    Location
    Guildford, Surrey
    Posts
    23,002
    Thanks
    11,051
    Thanks Received
    15,006

    Default Re: Pachislo Net machine power up issue blows 8 amp fuse

    You should always run on the correct voltage transformer. there maybe other underlying problems. but until you know you have the correct supply. you will never know.
    There is a chance that the machine may previously been plugged in without a transformer and damaged the main PSU
    Ian #UKPachinko

  3. #3
    Tokie Owens dynaglide36's Avatar
    Join Date
    Dec 2018
    Location
    Select...salmon arm
    Posts
    2
    Thanks
    0
    Thanks Received
    0

    Default Re: Pachislo Net machine power up issue blows 8 amp fuse

    Quote Originally Posted by Drunkenclam View Post
    You should always run on the correct voltage transformer. there maybe other underlying problems. but until you know you have the correct supply. you will never know.
    There is a chance that the machine may previously been plugged in without a transformer and damaged the main PSU


    Hmmmmm ?? thx for the reply ya the transformer putting out 29 or 30 volts shouldn't have blown the fuse. as i have now tested a couple other machines and they put out close to 28v as well. with no load on them. And the transformer has been in the pachislo for awhile as being converted to our 115 volts from chinas 100. i picked up the net machine and it had no power supply to start with and the transformer was in it already, and is very clean inside and out. I thought i would get a power supply and give it a go and see if it powered up. Well after i get the power supply repaired or checked out i will try it with just power coming in not hooked up to the main psu. and see what happens. thx again

Similar Threads

  1. Power AT issue
    By Rmasters3 in forum Pachislo Technical Support Tickets
    Replies: 2
    Last Post: 03-26-2017, 03:03 PM
  2. Zangus pachislo blows 8 amp fuse on Power up.
    By eaglefan44 in forum Pachislo Technical Support Tickets
    Replies: 6
    Last Post: 04-06-2015, 03:44 PM
  3. Issue with a pachislo machine. Please Help
    By michael382 in forum Pachislo Technical Support Tickets
    Replies: 2
    Last Post: 09-26-2012, 02:15 PM
  4. Olympia Excellence Twist, fuse blows
    By Hwiggins01 in forum Pachislo Technical Support Tickets
    Replies: 16
    Last Post: 07-10-2012, 06:37 PM
  5. Fuse or Power Issue E.T.
    By Frank A in forum Pachinko Technical Support Tickets
    Replies: 13
    Last Post: 03-07-2007, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •